What are the system requirements for KaleidaGraph for Mac?

OS 10.4 up through OS 10.14

If you are running OS 10.7 through 10.9.1, you must use v4.1.3 or v4.5 of KaleidaGraph.

If you are running OS 10.9.2 – OS 10.14 (including Yosemite, El Capitan,  Sierra, High Sierra, or Mojave), you should use v4.5.4 of KaleidaGraph.

60 MB of free hard disk space is recommended.

Scroll to Top