I get an error that PowerPC applications are no longer supported.

The installers for v4.0 and earlier cannot be used under OS 10.7 or later. If you have KaleidaGraph 4 on another computer, you can copy your KaleidaGraph 4.0 folder onto the new computer and run the v4.1.3 updater that is available from our website.

Users of v3.6 or earlier will need to purchase an upgrade. If you get the physical upgrade, you will get a CD that will perform a complete installation.

Scroll to Top